linux(centos7)下安装vnpy2的坑

vnpy源码解读 专栏收录该内容
9 篇文章 30 订阅

1、gcc版本过低。

vnpy2要求c++ 17以上,但是老的linux系统都不支持,所以需要升级一下。

vnpy2对linux下gcc编译器的版本要求较高,会出现这样的错误:

我们可以发现,gcc是2015年的,版本确实是低。

然后我们就来升级一下。

然后我们就可以看到,gcc获得了升级。

2、编译的问题。

安装好了gcc,我们在运行vnpy里面的install.sh,有的同学可能又会碰到一些别的问题,比如有些编译源码不在。比如笔者下载的vnpy的版本中,编译的时候就说eos里面的一个class_one什么的c文件不存在。这个eos是一个api,其实我们不需要,所以我们其实可以在编译的时候去掉eos的编译。

这个在setup.py文件里面修改。

这个文件里面提到的eos的地方都删掉。

然后我们再运行就可以完美编译安装了。

  • 0
    点赞
  • 0
    评论
  • 3
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值